3.1. BDR requirements

To use logical replication via BDR you will need PostgreSQL 9.4. Earlier versions are not supported and will never be supported.

BDR 1.0 requires a modified version of PostgreSQL 9.4. This modified PostgreSQL adds functionality BDR needs to support DDL replication, multi-master last-update-wins conflict resolution, user-defined conflict handlers, etc. This modified version of PostgreSQL 9.4 is available from the BDR download page alongside the extension in both package and source form. This requirement means that you can't use BDR on unmodified PostgreSQL 9.4.

Note: All the new features required have been submitted for inclusion in PostgreSQL. Many have already been accepted and included. If all the functionality BDR requires is added to PostgreSQL then the need for a modified PostgreSQL will go away in the next version.

Some of these modifications make small changes to PostgreSQL data directory. As a result the modified PostgreSQL 9.4 used by BDR can't load data directories from unmodified PostgreSQL and vice versa. Users must dump and reload their database(s) to switch to a BDR-capable PostgreSQL. See Installation.

BDR 2.0 supports PostgreSQL 9.6. See the BDR 2.0 documentation and the BDR website for the latest information.

BDR 1.0 does not support Microsoft Windows.