This page in other versions: 0.9 / 1.0 / 1.0.3

3.1. BDR / UDR requirements

To use logical replication via BDR or UDR you will need PostgreSQL 9.4 or newer. Earlier versions are not supported and will never be supported.

Currently BDR requires a modified version of PostgreSQL 9.4. This modified PostgreSQL adds functionality BDR needs to support DDL replication, multi-master last-update-wins conflict resolution, user-defined conflict handlers, etc. This modified version of PostgreSQL 9.4 is available from the BDR download page alongside the extension in both package and source form. This requirement means that you can't use BDR on unmodified PostgreSQL 9.4.

Note: All the new features required have been submitted for inclusion in PostgreSQL 9.5. Many have already been accepted and included. If all the functionality BDR requires is added to PostgreSQL 9.5 then the need for a modified PostgreSQL will go away in the next version.

Some of these modifications make small changes to how PostgreSQL stores data on disk. As a result the modified PostgreSQL 9.4 used by BDR can't load data directories from unmodified PostgreSQL and vice versa. Users must dump and reload their database(s) to switch to a BDR-capable PostgreSQL, or use UDR for online-upgrade. See Installation.

UDR runs on standard PostgreSQL 9.4 and is installed like any other extension. It is a cut-down version of BDR that can work with only the features present in PostgreSQL 9.4; see Section 1.5.

As of the time of writing, the upcoming PostgreSQL 9.5 release is not yet supported. Neither is Microsoft Windows. Support for both will be added in later releases; please check the BDR website for the latest information.